Troubleshooting ESXi 6.5 upgrade – Upgrade contains Conflicting VIBs

It is vSphere 6.5 upgrade session. Most of us will be working with upgrading vCenter 6.0 to vCenter 6.5 or even with migrating your windows vCenter 6.0 to vCenter Server appliance 6.5 at least in lab environment. I was working on upgrade VMware ESXi 6.0 to ESXi 6.5 using update manager. I ran through the upgrade for many of the hosts. I came across the issue on few of the HP blade servers and my update manager for ESXi 6.5 upgrade is showing as “incompatible” and it throws the error related to the conflicting VIB’s. . In my case, conflicting VIB’s are related to Mellanox. Error also shows that remove the conflicting VIBs or use image builder to create a custom upgrade ISO image that contains the newer versions of the conflicting VIBs and try to upgrade again.In article, I will explain how to troubleshoot the conflicting VIB’s during ESXi 6.5 upgrade.

Troubleshooting ESXi 6.5 upgrade – Conflicting VIBs:

It is clear that ESXi 6.5 upgrade baseline is showing as “incompatible” during the Scan for upgrades in the update manager. so we need to remove the conflicting VIB’s from the esxi host.

ESXI 6.5 Upgrade

 

Before removing the conflicting VIB’s from the ESXi host, we need to validate that whether ESXi host are using Mellanox drivers for your network adapter or not. If it is used by ESxi host, DO NOT remove them. Removing the VIBs which are used by your network adapter will disconnect all your network interfaces from the ESXi host. You can validate the drivers used by the network adpaters using the below command

esxcli network nic list

ESXi 6.5 Upgrade

None of the network adapters in the ESXi is using the Mellanox drivers for the ESXi network adapter. I am good and safe to remove the conflicting Mellanox VIB’s.  Connect to the ESXi host using SSH and execute the below command

esxcli software vib list | grep Mel  or  esxcli software vib list | grep 550

ESXi 6.5 Upgrade

Find the VIB name from the above command. In my case, VIB name is “net-mst”. Execute the below command to remove the problematic conflicting VIB using the below command.

esxcli software vib remove -n net-mst

ESXi 6.5 upgrade -Conflicting VIBS_3

That’s it Mellanox vib is removed from the ESXi host and reboot the esxi host for the changes to take effect. Scan again the ESXi host using Update Manager and ESxi  6.0 host will be ready for ESXi 6.5 Upgrade. Upgrade to ESXi 6.5 and make use of the latest features available with vSphere 6.5. I hope this is informative for you. Thanks for Reading!!. Be social and share it in social media, if you feel worth sharing it.

The post Troubleshooting ESXi 6.5 upgrade – Upgrade contains Conflicting VIBs appeared first on VMware Arena.


This post was originally published on this site
Comments are closed.